1.2.2.6

Обкатка новых функций сплиттера и исправление текущих ошибок перед внедрением в основной код

Re: 1.2.2.6

Сообщение void » 29 апр 2012, 18:36

vaho писал(а):только haali работает как сплиттер напрямую

В нижнем регистре субтип пишет.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Объявление

Re: 1.2.2.6

Сообщение vaho » 29 апр 2012, 19:18

void писал(а):
vaho писал(а):только haali работает как сплиттер напрямую

В нижнем регистре субтип пишет.

Возможно, в этом причина. Но тот же haali почему-то открывает только indeo5 (и поддерживает эскиз), indeo3 открывает, но не поддерживает эскиз. а indeo4 не открывает вообще.
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.6

Сообщение void » 30 апр 2012, 09:54

В виндовс Indeo кодеки заблокированы в связи с найденной уязвимостью.
Скорбим :)
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.6

Сообщение vaho » 30 апр 2012, 16:14

void писал(а):В виндовс Indeo кодеки заблокированы в связи с найденной уязвимостью.
Скорбим :)

Читал эту февральскую заметку. Но мы-то ведем речь не о виндовских Indeo vfw кодеках (и их библиотеках с уязвимостью) работающих через avi decompressor, а о DS фильтрах (ffdshow, mpc video decoder, lav video), которые подключаются автоматически только к haali, а к остальным сплиттерам (MS AVI, AVS, LAV) - только если сплиттер подключен к виндовскому file source.
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.6

Сообщение void » 30 апр 2012, 16:46

Полагаю что винда блокирует редеринг пина с fourcc IV**, а нижний регистр не определяется как indeo, поэтому рендер и срабатывает. Однако не понятно почему все начинает работать при загруженном в граф системном сурсе.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.6

Сообщение vaho » 30 апр 2012, 17:19

void писал(а):Полагаю что винда блокирует редеринг пина с fourcc IV**, а нижний регистр не определяется как indeo, поэтому рендер и срабатывает. Однако не понятно почему все начинает работать при загруженном в граф системном сурсе.

Да бог с ним с этим indeo, разберетесь - хорошо, нет - тоже не страшно. В конце концов это древний кодек. Вот есть другая проблема - с новыми кодеками lagarith и utvideo: проводник вызывает для генерации эскиза сплиттер (причем даже в том случае, когда AV не прописан как сурс для avi) и тот намертво виснет в трее, убрать можно только убив процесс dllhost.exe и то не всегда получается. Конечно можно на 64 битной винде снять галку с avi на инпуте в 64 битной версии сплиттера оставив только в 32 битной, но это будет полумерой.
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.6

Сообщение void » 01 май 2012, 09:57

vaho писал(а):с новыми кодеками lagarith и utvideo: проводник вызывает для генерации эскиза сплиттер (причем даже в том случае, когда AV не прописан как сурс для avi) и тот намертво виснет в трее,

Текущая x64 версия у меня не виснет. Проверял на файле utvideo(00h00m00s-00h00m07s).avi, в ffdshow включена поддержка Raw video и установлен utvideo-10.2.0-win-x64.msi. http://umezawa.dyndns.info/archive/utvideo/
Конечно можно на 64 битной винде снять галку с avi на инпуте в 64 битной версии сплиттера оставив только в 32 битной, но это будет полумерой.

Еще можно запретить загрузку в процесс dllhost.exe.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.6

Сообщение vaho » 01 май 2012, 13:50

void писал(а):
vaho писал(а):с новыми кодеками lagarith и utvideo: проводник вызывает для генерации эскиза сплиттер (причем даже в том случае, когда AV не прописан как сурс для avi) и тот намертво виснет в трее,

Текущая x64 версия у меня не виснет. Проверял на файле utvideo(00h00m00s-00h00m07s).avi, в ffdshow включена поддержка Raw video и установлен utvideo-10.2.0-win-x64.msi. http://umezawa.dyndns.info/archive/utvideo/
Конечно можно на 64 битной винде снять галку с avi на инпуте в 64 битной версии сплиттера оставив только в 32 битной, но это будет полумерой.

Еще можно запретить загрузку в процесс dllhost.exe.

Тоже перепроверил. Проблема была с сэмплами, изготовленными с не совсем новыми версиями lagarith и utvideo. Изготовил самостоятельно на новейших версиях и все фунциклирует. Так что можно сказать вопрос снят.
Таким образом за исключением трабла с indeo и пожелания по добавлению галки наличия внешних субтитров в подключения графбилдера других замечаний нет.
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Пред.

Вернуться в Тестовые сборки

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron