1.2.2.15

Обкатка новых функций сплиттера и исправление текущих ошибок перед внедрением в основной код

Re: 1.2.2.15

Сообщение vitsat » 24 июн 2013, 12:59

В последних билдах MPC-BE перестал коннектиться CyberLink Video Decoder (PDVD13) на WMV3 и WVC1 в контейнере .wmv только в Win7 (любой разрядности)
Изображение
Изображение
Даже если CyberLink Video Decoder (PDVD13) отметить кнопкой "Предпочесть" во внешних фильтрах MPC-BE , то он всё равно не цепляется к системному ASF Reader , а также к LAV Splitter. В XP любые сочетания работают.

В PotPlayer (сборка 7sh3) CyberLink Video Decoder (PDVD13) цепляется к AV Splitter и к системному ASF Reader, и к LAV Splitter , т.е. любые сочетания работают в XP и в Win7
Правда в сборке PotPlayer от 7sh3 все фильтры независимые (расположены в прог. папке)

P.S. Последний билд, где не было проблем в Win7 с коннектом CyberLink Video Decoder (PDVD13) на WMV3 и WVC1 в контейнере .wmv - это MPC-BE.1.1.0.0.1914.x86
vitsat
 
Сообщения: 43
Зарегистрирован: 26 сен 2011, 09:36

Объявление

Re: 1.2.2.15

Сообщение Aleksoid1978 » 25 июн 2013, 09:29

Я понимаю что где-то "накосячил" в графопостроителе. Но вот понять бы что может быть не так ... И еще вопрос - на скрине почему-то subtype : DXVA_Intel_VC1_ClearVideo, это запускаем на Intel HD. Еще просьба - запустить в графстудии и посмотреть какой там будет subtype от Cyberlink к видео-рендереру.
Aleksoid1978
 
Сообщения: 7
Зарегистрирован: 23 авг 2011, 05:34

Re: 1.2.2.15

Сообщение void » 26 июн 2013, 10:26

vitsat
У меня из киберлинк декодеров только 11 и 12, дайте ссылку на 13-й.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.15

Сообщение karinas » 26 июн 2013, 13:00

karinas
 
Сообщения: 8
Зарегистрирован: 01 апр 2012, 13:04

Re: 1.2.2.15

Сообщение vitsat » 27 июн 2013, 06:41

У меня из киберлинк декодеров только 11 и 12, дайте ссылку на 13-й.

Без разницы. Не цепляется никакой от 10-го до 13-го
И еще вопрос - на скрине почему-то subtype : DXVA_Intel_VC1_ClearVideo, это запускаем на Intel HD.

Интересно, что карта Radeon 4350
vitsat
 
Сообщения: 43
Зарегистрирован: 26 сен 2011, 09:36

Re: 1.2.2.15

Сообщение void » 27 июн 2013, 13:24

Я 13-й в графстудии на семпле .wmv vc1 немного проверил. К сплитеру декодер подключается, а к EVR рендеру - нет, возможно из-за не стандартного дефолтного медиатипа на выходном пине у киберлинк13.
Смена структуры VIDEINFO2 на MPEG2VIDEO возвращает медиатип с субтипом NV12 на место и соответственно подключение кибера13 к рендеру, но увы, при таком раскладе декодер уже не работает.
Думаю нужно пробовать после установки декодера вносить изменения в filterdata, примерно так же как это практиковалось с 11й версией.
У меня 11 и 12 работают в графстудии без нареканий, в МРС еще не пробовал.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.15

Сообщение Aleksoid1978 » 28 июн 2013, 00:38

Дайте ссылку на 11 и 12 версии Cyberlink Video Decoder.
Aleksoid1978
 
Сообщения: 7
Зарегистрирован: 23 авг 2011, 05:34

Re: 1.2.2.15

Сообщение Aleksoid1978 » 28 июн 2013, 05:57

void писал(а):Я 13-й в графстудии на семпле .wmv vc1 немного проверил. К сплитеру декодер подключается, а к EVR рендеру - нет, возможно из-за не стандартного дефолтного медиатипа на выходном пине у киберлинк13.
Смена структуры VIDEINFO2 на MPEG2VIDEO возвращает медиатип с субтипом NV12 на место и соответственно подключение кибера13 к рендеру, но увы, при таком раскладе декодер уже не работает.
Думаю нужно пробовать после установки декодера вносить изменения в filterdata, примерно так же как это практиковалось с 11й версией.
У меня 11 и 12 работают в графстудии без нареканий, в МРС еще не пробовал.


От декодера к рендереру должен идти именно formattype: FORMAT_VideoInfo2, MPEG2VIDEO - это только от сплиттера к декодеру.
Aleksoid1978
 
Сообщения: 7
Зарегистрирован: 23 авг 2011, 05:34

Re: 1.2.2.15

Сообщение vitsat » 28 июн 2013, 06:51

Видеофильтры из последних билдов PDVD 10,11,12 : http://rghost.ru/47069514
vitsat
 
Сообщения: 43
Зарегистрирован: 26 сен 2011, 09:36

Re: 1.2.2.15

Сообщение void » 28 июн 2013, 12:54

Aleksoid1978 писал(а):
void писал(а):Я 13-й в графстудии на семпле .wmv vc1 немного проверил. К сплитеру декодер подключается, а к EVR рендеру - нет, возможно из-за не стандартного дефолтного медиатипа на выходном пине у киберлинк13.
Смена структуры VIDEINFO2 на MPEG2VIDEO возвращает медиатип с субтипом NV12 на место и соответственно подключение кибера13 к рендеру, но увы, при таком раскладе декодер уже не работает.
Думаю нужно пробовать после установки декодера вносить изменения в filterdata, примерно так же как это практиковалось с 11й версией.
У меня 11 и 12 работают в графстудии без нареканий, в МРС еще не пробовал.


От декодера к рендереру должен идти именно formattype: FORMAT_VideoInfo2, MPEG2VIDEO - это только от сплиттера к декодеру.

Речь о субтипе выходного пина декодера. У киберлинка 13 он другой.
outpp.png
outpp.png (30 КБ) Просмотров: 2138


Смена структуры VIDEINFO2 на MPEG2VIDEO возвращает медиатип с субтипом NV12 на место и соответственно подключение кибера13 к рендеру,

formattype в экспериментальных целях я менял в настройках авсплитера.
mtype.png
mtype.png (39.99 КБ) Просмотров: 2138
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Пред.След.

Вернуться в Тестовые сборки

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron