1.2.2.6

Обкатка новых функций сплиттера и исправление текущих ошибок перед внедрением в основной код

1.2.2.6

Сообщение void » 20 апр 2012, 15:33

avsplitter_x86_1.2.2.6.zip
(2.12 МБ) Скачиваний: 1598

avsplitter_x64_1.2.2.6.zip
(2.42 МБ) Скачиваний: 622


Исправлено:
Баг переключения субтитров версии 1.2.2.5 http://forum.avmedia.su/viewtopic.php?f=7&p=1487#p1486
Баг с окончанием воспроизведения появившийся в версии 1.2.2.4
Воспроизведение AVI AV Splitter + ffdshow Video = blackscreen
Перемотка Blu-ray http://forum.avmedia.su/viewtopic.php?f=7&t=188#p1470
Переподключение фильтров http://forum.avmedia.su/viewtopic.php?f=8&t=190&p=1462#p1456
--------------------------------------------------------------------------------------------------------------------------------------
Отключен ffmpeg аудио медиатип.
Добавлено определение mpeg4 ALS кодека Проблема с аудио als воспроизведение работает с неофициальной сборкой ffdshow
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Объявление

Re: 1.2.2.4

Сообщение wanezhiling » 20 апр 2012, 15:51

:) Many thanks, Eduard.
wanezhiling
 
Сообщения: 57
Зарегистрирован: 11 окт 2011, 12:14

Re: 1.2.2.4

Сообщение A55555 » 20 апр 2012, 18:15

Очень интересный косяк принесла эта сборка. Ни MPC, ни LA не могут по окончании воспроизведения выполнить опцию типа "По окончании воспроизведения закрыть плеер". С предыдущими версиями в этом плане OK :)
Например на этом файле MPEG2_sputnic_droganie[TEST]2.mpg http://us.ua/760824/
И нельзя ли на нём же глянуть почему теперь переходит в дрожь на срыве, раньше с Elecard-ом такого не было (напр в версии 1.2.2.1)
A55555
 
Сообщения: 181
Зарегистрирован: 07 сен 2011, 20:16

Re: 1.2.2.4

Сообщение void » 21 апр 2012, 05:00

A55555 писал(а):Очень интересный косяк принесла эта сборка. Ни MPC, ни LA не могут по окончании воспроизведения выполнить опцию типа "По окончании воспроизведения закрыть плеер"

Да, есть такое. Ави невнимательно исправил.
Собственно баг исправил и перезалил в текущюю тему.
A55555 писал(а):И нельзя ли на нём же глянуть почему теперь переходит в дрожь на срыве, раньше с Elecard-ом такого не было (напр в версии 1.2.2.1)

Видимо это происходит только в конфигурации ATI+XP, я могу протестировать IntelHD + XP, ATI + Win7 и IntelHD + Win7, но к сожалению на всех системах Elecard успешно восстанавливается после сбойного участка.
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.5

Сообщение A55555 » 21 апр 2012, 06:31

void писал(а):Видимо это происходит только в конфигурации ATI+XP

Именно такая связка :( Со стартом с Elecard всё норм.
Теперь с АРКсофт хорошо проходит этот сбой, но вот этот кусочек не может проиграть (на первом кадре стоит изображение) в связке с АРКсофт http://us.ua/761395/ (c Elecard может)

По вот этому вопросу стало намного лучше viewtopic.php?f=8&t=77#p1478 но ещё не до конца.
A55555
 
Сообщения: 181
Зарегистрирован: 07 сен 2011, 20:16

Re: 1.2.2.5

Сообщение vaho » 21 апр 2012, 09:36

как вижу, пока непонятка с кодеками indeo осталась - декодер не подключается автоматически и при попытке проводника создать эскиз дергается иконка сплиттера в трее
кроме того, в последних двух версиях полностью сломалось воспроизведение аудио indeo - вылетает с ошибкой графстудия, а проводник вообще падает пытаясь создать эскиз
сэмпл с indeo audio - indeo5_video_indeoaudio.avi http://sendfile.su/577010
сам декодер iac25 32.ax в папке Syswow64 (или в System32 в случае W7x86)
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.5

Сообщение usalex » 21 апр 2012, 20:41

А мне этот билд понравился.
Есть у меня фильмец (название: "Страница 8") - на предыдущем билде совместно с ffdshow DXVA декодером при прыжках колёсиком мыши (средний переход в MPC-HC) плеер падал, а на этом билде нормально крутит взад-вперед эту MKV-шку и не мяукает. :)
Спасибо!
usalex
 
Сообщения: 19
Зарегистрирован: 08 апр 2012, 11:36

Re: 1.2.2.5

Сообщение void » 21 апр 2012, 21:30

Как бы некоторые вопросы связанные с воспроизведением не феншуйных форматов( и не только) можно порешать с черного входа http://forum.avmedia.su/viewtopic.php?f=11&t=194
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.5

Сообщение A55555 » 21 апр 2012, 21:58

Чёто совсем с субтитрами в этой версии не благополучно. Видео The.Twilight.Saga.Breaking.Dawn.Part.1.2011.x264.BDRip.AVC (1)-007.mkv http://minus.com/mwlUlketB#1g
Переключаем напр на украинские, просто их не будет показывать, переключаем напр на 3-и русские вообще стоп_видео/чёрный_прямоугольник.
Это не только в mkv, в блюреях тоже, какие-то показывает субтитры, какие-то не хочет.
A55555
 
Сообщения: 181
Зарегистрирован: 07 сен 2011, 20:16

Re: 1.2.2.5

Сообщение void » 22 апр 2012, 04:22

A55555 писал(а): с субтитрами в этой версии не благополучно.

Подтверждаю, баг серьезный. Появился после исправления переподключения фильтров http://forum.avmedia.su/viewtopic.php?f=8&t=190&p=1462#p1456
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

След.

Вернуться в Тестовые сборки

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron