1.2.2.3

Обкатка новых функций сплиттера и исправление текущих ошибок перед внедрением в основной код

Re: 1.2.2.3

Сообщение void » 04 апр 2012, 18:12

vaho писал(а):Вот этот файл indeo32.avi http://sendfile.su/564919

У меня нормально играет.
цепляется субтипом {32335649-0000-0010-8000-00AA00389B71} iv32

Интересно, что если удалить из графстудии Lav audio и подключить к аудиопину Direct Sound Device (или если просто запретить PCM в LAV audio), то после принудительной сцепки видеопина с ffdshow всё хокей, такие вот чудеса

Ничего страшного, бывает и хуже :D
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Объявление

Re: 1.2.2.3

Сообщение vaho » 04 апр 2012, 18:14

void писал(а):
vaho писал(а):Вот этот файл indeo32.avi http://sendfile.su/564919

У меня нормально играет.
цепляется субтипом {32335649-0000-0010-8000-00AA00389B71}


А у меня не цепляется. Может чего-то не правильно делаю?

c pcm видимо опять немец напортачил ибо в MPC все нормально c direct sound device и mpc video decoder на AV сплиттере

а вот в графстудии и соответственно с проводником windows какая-то лажа, проводник пытается создать эскиз и дергает AVS, значок AVS в трее дергается и ничего не выходит..
Последний раз редактировалось vaho 04 апр 2012, 18:23, всего редактировалось 1 раз.
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение void » 04 апр 2012, 18:23

vaho писал(а):А у меня не цепляется. Может чего-то не правильно делаю?

Да у меня тоже командой render pin не цепляет, только стрелками. Нужный субтип не дефолтный и похоже что ffdshow его не видит (это я предварительно предположил).
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.3

Сообщение vaho » 04 апр 2012, 18:32

void писал(а):
vaho писал(а):А у меня не цепляется. Может чего-то не правильно делаю?

Да у меня тоже командой render pin не цепляет, только стрелками. Нужный субтип не дефолтный и похоже что ffdshow его не видит (это я предварительно предположил).


Да, но дело в том, что я ради интереса позапрещал Indeo и в ffdshow и в lav video, так вот LAV splitter нормально проигрывает и через avi decompressor (vfw indeo...) причем и lav audio нормально работает с pcm в этом случае
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение vaho » 04 апр 2012, 19:21

и вот какие интересные ситуации с отключенными indeo в ffdshow и в LAV video и с включенным pcm в lav audio

Снимок1.png
LAV splitter
Снимок1.png (240.08 КБ) Просмотров: 4498


Снимок2.png
Haali
Снимок2.png (110.3 КБ) Просмотров: 4498


Снимок3.png
MS AVI splitter
Снимок3.png (125.43 КБ) Просмотров: 4498
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение vaho » 04 апр 2012, 19:41

Эти ситуации с включенным Indeo в lav video

Снимок5.png
LAV splitter
Снимок5.png (218.41 КБ) Просмотров: 4498


Снимок4.png
MS avi splitter
Снимок4.png (223.91 КБ) Просмотров: 4498


Снимок6.png
AV splitter
Снимок6.png (185.5 КБ) Просмотров: 4498
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение vaho » 04 апр 2012, 20:01

и наконец с включенным ffdshow

Снимок8.png
LAV splitter
Снимок8.png (252.1 КБ) Просмотров: 4497


Снимок9.png
Haali splitter
Снимок9.png (135.12 КБ) Просмотров: 4497


Снимок10.png
MS AVI splitter
Снимок10.png (170.67 КБ) Просмотров: 4497
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение void » 05 апр 2012, 13:54

vaho
Траблы с lav audio давно уже пройдены http://forum.avmedia.su/viewtopic.php?f=7&t=169#p1221
В данном случае все тоже самое - сбилось соответствие ID кодеков.
Думаю либо совсем убрать самопальный ffmpeg медиатип или сделать включение опцией.
upv писал(а):http://us.ua/712625/ av+lav audio в MPC-HC и PotPlayer не слышно центрального канала
В GB все ок

Возможно та же причина. Каким медиатипом lav audio цепляется в MPC-HC и PotPlayer ?
void
Администратор
 
Сообщения: 687
Зарегистрирован: 26 июл 2011, 15:22

Re: 1.2.2.3

Сообщение vaho » 05 апр 2012, 14:58

void писал(а):vaho
Траблы с lav audio давно уже пройдены http://forum.avmedia.su/viewtopic.php?f=7&t=169#p1221
В данном случае все тоже самое - сбилось соответствие ID кодеков.
Думаю либо совсем убрать самопальный ffmpeg медиатип или сделать включение опцией.


Да я тоже так подумал, что опять сбилось соответствие ID кодеков.

Но вот интересно с чем связано неподключение автоматически (а только принудительно) видеодеков indeo у Haali (вспомнил. что так было у него всегда) и в последних версиях AV?
vaho
 
Сообщения: 205
Зарегистрирован: 02 окт 2011, 07:32

Re: 1.2.2.3

Сообщение nixties » 06 апр 2012, 17:05

AVSplitter c Arcsoft Video Decoder на некоторых MPEG-PS вызывает зависание картинки в начале воспроизведения - Дискотека_Авария_ft._Джиган___Вика_Крутая_-_Карнавал_(SatRip).mpg
nixties
 
Сообщения: 15
Зарегистрирован: 27 авг 2011, 06:16

Пред.След.

Вернуться в Тестовые сборки

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron